win7启动Vue项目

2022-06-21 走过路过 26 0

    新版本的node.js已经不支持win7操作系统,其最多只能用node.js的v13.14.0。所以安装vue/cli时不能安装最新版,得装指定版本。步骤如下:

1. 下载安装node.js
因为Win7系统最多只能安装v13.14.0,下载地址:https://nodejs.org/download/release/v13.14.0/

2.配置淘宝镜像
执行命令:npm install -g cnpm --registry=https://registry.npm.taobao.org
如果网络较好,可以不执行本步骤。

3. 安装vue/cli
在node.js的v13.14.0下直接执行 npm uninstall -g @vue/cli
会报错误:Cannot find module ‘fs/promises‘,这时你得执行安装指定版本的vue/cli
执行命令:npm install -g @vue/cli@3.11.0

4. 启动vue项目
cd xx 进入项目根目录。
如果没有node_modules,则执行命令:npm install 安装模块。
然后直接启动项目:npm run dev

会看到启动成功的提示:Your application is running here: http://localhost:8080

相关推荐
全部评论 最新评论 最早评论
还没有用户评论

联系我们